WordPress 4.7.2 Security Update

WordPress

We have an update from the WordPress team and WordPress 4.7.2 is now available. This is a security release for all previous versions and we strongly encourage you to update your sites immediately. It’s great to see another update addressing some fairly serious security issues. This is a good sign of well-maintained software. Kudos to the team over at WordPress.

WordPress versions 4.7.1 and earlier are affected by three security issues:

  1. The user interface for assigning taxonomy terms in Press This is shown to users who do not have permissions to use it. Reported by David Herrera of Alley Interactive.
  2. WP_Query is vulnerable to a SQL injection (SQLi) when passing unsafe data. WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability. Reported by Mo Jangda (batmoo).
  3. A cross-site scripting (XSS) vulnerability was discovered in the posts list table. Reported by Ian Dunn of the WordPress Security Team.

Download WordPress 4.7.2 or venture over to Dashboard → Updates and simply click “Update Now.” Sites that support automatic background updates are already beginning to update to WordPress 4 look at more info.7.2.